Gnome UI is now optional.
[udpgate.git] / src / Makefile.am
index 59e0d8f..2ca3bad 100644 (file)
@@ -29,6 +29,13 @@ GLADE_OUT= \
                ui-gnome-support.c \
                ui-gnome-support.h
 
+if HAVE_GNOME
+GNOME_SRCS= \
+               ui-gnome.c \
+               ui-gnome.h \
+               $(GLADE_OUT)
+endif
+
 udpgate_SOURCES= \
                main.c \
                main.h \
@@ -36,11 +43,9 @@ udpgate_SOURCES= \
                network.h \
                packet.c \
                packet.h \
-               ui-gnome.c \
-               ui-gnome.h \
                ui-line.c \
                ui-line.h \
-               $(GLADE_OUT)
+               $(GNOME_SRCS)
 
 EXTRA_DIST+= \
                $(GLADE_IN)
@@ -63,7 +68,7 @@ CLEANFILES+= \
                ui-gnome.glade.bak \
                ui-gnome.gladep.bak
 
-udpgate_LDADD+= $(POPT_LIBS) $(INTLLIBS)
+udpgate_LDADD+=$(POPT_LIBS) $(INTLLIBS)
 
 # FIXME: /usr/include/gtk-2.0/gtk/gtkitemfactory.h:51: warning: function declaration isn't a prototype
 # /* We use () here to mean unspecified arguments. This is deprecated