Release: 1.1.7
[captive.git] / src / install / acquire / cabextract / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=2
10
11 configure: configure-stamp
12 configure-stamp:
13         dh_testdir
14         # Add here commands to configure the package.
15         ./configure --prefix=$(CURDIR)/debian/cabextract/usr --mandir=$(CURDIR)/debian/cabextract/usr/share/man --infodir=$(CURDIR)/debian/cabextract/usr/share/info
16         
17
18         touch configure-stamp
19
20 build: configure-stamp build-stamp
21 build-stamp:
22         dh_testdir
23
24         # Add here commands to compile the package.
25         $(MAKE)
26         #/usr/bin/docbook-to-man debian/cabextract.sgml > cabextract.1
27
28         touch build-stamp
29
30 clean:
31         dh_testdir
32         dh_testroot
33         rm -f build-stamp configure-stamp
34
35         # Add here commands to clean up after the build process.
36         -$(MAKE) clean
37
38         dh_clean
39
40 install: build
41         dh_testdir
42         dh_testroot
43         dh_clean -k
44         dh_installdirs
45
46         # Add here commands to install the package into debian/cabextract.
47         \$(MAKE) install
48
49
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
53
54 # Build architecture-dependent files here.
55 binary-arch: build install
56         dh_testdir
57         dh_testroot
58 #       dh_installdebconf       
59         dh_installdocs
60         dh_installexamples
61         dh_installmenu
62 #       dh_installemacsen
63 #       dh_installpam
64 #       dh_installinit
65         dh_installcron
66         dh_installmanpages
67         dh_installinfo
68 #       dh_undocumented
69         dh_installchangelogs 
70         dh_link
71         dh_strip
72         dh_compress
73         dh_fixperms
74 #       dh_makeshlibs
75         dh_installdeb
76 #       dh_perl
77         dh_shlibdeps
78         dh_gencontrol
79         dh_md5sums
80         dh_builddeb
81
82 binary: binary-indep binary-arch
83 .PHONY: build clean binary-indep binary-arch binary install configure