http://prdownloads.sourceforge.net/lufs/lufs-0.9.7.tar.gz?download
[lufs.git] / lufs.spec
1 # Your kernel version, tries to auto-detect here
2 %define kernelversion %(uname -r)
3
4 %define name    lufs
5 %define version 0.8.2
6
7 Summary:        lufs - Linux Userland File System
8 Name:           %{name}
9 Version:        %{version}
10 Release:        1
11 License:        GPL
12 Group:          Base
13 Source0:        %{name}-%{version}.tar.gz
14 Patch1:     lufs-rpmbuild.patch
15
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libtool
19 #BuildRequires: kernel-source = %{kernelversion}
20
21 Requires:   kernel = %{kernelversion}
22
23 BuildRoot:      /tmp/buildroot-%{name}-%{version}
24
25 %description
26 LUFS is a hybrid userspace filesystem framework supporting many filesystems:
27 sshfs, ftpfs, localfs, locasefs, gvfs, cardfs, cefs, etc.  Lots of other 
28 "exotic" filesystems are in the planning phase: socketfs, httpfs, freenetfs
29 and others.
30
31
32 %prep
33 %setup -q
34
35 %patch1 -p1
36
37 %build
38 %{__libtoolize}
39 aclocal
40 %{__autoconf}
41 %{__automake}
42 %configure \
43         --with-kernel=%{kernelversion} \
44         --with-kheaders=/lib/modules/%{kernelversion}/build/include 
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57
58 ln -s /usr/bin/auto.sshfs /etc/auto.sshfs
59 ln -s /usr/bin/auto.ftpfs /etc/auto.ftpfs
60 ln -s /usr/bin/lufsd /sbin/mount.lufs
61
62 depmod -a
63
64 if [ "`lsmod | grep lufs`" ]; then rmmod lufs; fi
65
66 modprobe lufs
67
68 %preun
69
70 if [ "`lsmod | grep lufs`" ]; then rmmod lufs; fi
71
72 %postun
73
74 depmod -a
75
76 rm -f /etc/auto.sshfs
77 rm -f /etc/auto.ftpfs
78 rm -f /sbin/mount.lufs
79
80
81 %files
82 %defattr(644,root,root)
83
84 /lib/modules/%{kernelversion}/kernel/fs/lufs/lufs.o
85 /etc/lufsd.conf
86
87 %defattr(755,root,root)
88
89 /usr/bin/lufsd
90 /usr/bin/lussh
91 /usr/bin/lufsmount
92
93 /usr/bin/auto.sshfs
94 /usr/bin/auto.ftpfs
95
96 # These are SUID root...
97
98 %defattr(4755,root,root)
99 /usr/bin/lufsmnt
100 /usr/bin/lufsumount
101
102
103 %changelog
104 * Sun Nov 24 2002 Dave Wilson <dave@...>
105 - initial version