d6cee6d6070c47c9b3f8b897fd10c4450d8110cd
[nethome.git] / src / rpm / SPECS / cvs.spec
1 %define nokerberos 1
2 Summary: A version control system.
3 Name: cvs
4 Version: 1.11
5 Release: 3_nokerberos_static_badroot
6 Copyright: GPL
7 Group: Development/Tools
8 Source: ftp://ftp.cvshome.org/pub/cvs-%{version}/cvs-%{version}.tar.gz
9 URL: http://www.cvshome.org/
10 Patch0: cvs-1.10-tmprace.patch
11 Patch1: cvs-1.10.7-fixinfo.patch
12 Patch2: cvs-1.10.7-krb5-1.1.1.patch
13 Patch3: cvs-1.10.8-krb4.patch
14 Patch4: cvs-1.10.8-zlib.patch
15 Patch6: cvs-1.10.8-errno.patch
16 Patch7: cvs-1.11-security.patch
17 Patch8: cvs-1.11-existence.patch
18 Patch100: cvs-1.11-umask022.patch
19 Patch101: cvs-1.11-badroot.patch
20 Prereq: /sbin/install-info
21 Prefix: %{_prefix}
22 Buildroot: %{_tmppath}/%{name}-root
23 Requires: perl zlib
24 BuildPreReq: autoconf libtool zlib-devel
25 %{!?nokerberos:Requires: krb5-libs}
26 %{!?nokerberos:BuildPrereq: krb5-devel}
27
28 %description
29 CVS (Concurrent Version System) is a version control system which can
30 record the history of your files (usually, but not always, source
31 code). CVS only stores the differences between versions, instead of
32 every version of every file you've ever created. CVS also keeps a log
33 of who, when and why changes occurred.
34
35 CVS is very helpful for managing releases and controlling the
36 concurrent editing of source files among multiple authors. Instead of
37 providing version control for a collection of files in a single
38 directory, CVS provides version control for a hierarchical collection
39 of directories consisting of revision controlled files.  These
40 directories and files can then be combined together to form a software
41 release.
42
43 Install the cvs package if you need to use a version control system.
44
45 %prep
46 %setup -q
47 %patch0 -p1 -b .tmprace
48 %patch1 -p1 -b .fixinfo
49 %{!?nokerberos:%patch2 -p1 -b .krb5}
50 %{!?nokerberos:%patch3 -p1 -b .krb4}
51 %patch4 -p1 -b .zlib
52 %patch6 -p1 -b .errno
53 %patch7 -p1 -b .security
54 %patch8 -p1 -b .existence
55 %patch100 -p1 -b .umask022
56 %patch101 -p1 -b .badroot
57
58 %build
59 autoheader
60 autoconf
61 export LDFLAGS="-s -static -L$HOME/staticnss -lc -lnss_files -lnss_dns -lresolv"
62 %configure \
63 %{!?nokerberos: --with-gssapi=/usr/kerberos --with-krb4=/usr/kerberos --enable-encryption}
64
65 make
66 make -C doc info
67
68 %install
69 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
70
71 %{makeinstall} install-info
72 gzip $RPM_BUILD_ROOT/%{_infodir}/cvs* || true
73
74 %clean
75 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
76
77 %post
78 /sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
79 /sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir 
80
81 %preun
82 if [ $1 = 0 ]; then
83     /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
84     /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
85 fi
86
87 %files
88 %defattr(-,root,root)
89 %doc BUGS FAQ MINOR-BUGS NEWS PROJECTS TODO README
90 %doc doc/*.ps
91 /%{_bindir}/cvs
92 /%{_bindir}/cvsbug
93 /%{_bindir}/rcs2log
94 /%{_mandir}/man1/cvs.1*
95 /%{_mandir}/man5/cvs.5*
96 /%{_mandir}/man8/cvsbug.8*
97 /%{_infodir}/cvs*
98 /%{_libdir}/cvs
99
100 %changelog
101 * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
102 - fix cvs-1.11-security.patch, which had CR-LF line terminators (#25090)
103 - check for and ignore ENOENT errors when attempting to remove symlinks (#25173)
104
105 * Mon Jan 08 2001 Preston Brown <pbrown@redhat.com>
106 - patch from Olaf Kirch <okir@lst.de> to do tmp files safely.
107
108 * Tue Oct 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
109 - 1.11
110
111 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
112 - automatic rebuild
113
114 * Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
115 - always zero errno before calling readdir (#10374)
116
117 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
118 - rebuild in new build environment (release 6)
119
120 * Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
121 - rebuild in new build environment (release 5)
122 - FHS tweaks
123 - actually gzip the info pages
124
125 * Wed May 10 2000 Nalin Dahyabhai <nalin@redhat.com>
126 - reverse sense of conditional kerberos dependency
127 - add kerberos IV patch from Ken Raeburn
128 - switch to using the system's zlib instead of built-in
129 - default to unstripped binaries
130
131 * Tue Apr  4 2000 Bill Nottingham <notting@redhat.com>
132 - eliminate explicit krb5-configs dependency
133
134 * Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
135 - 1.10.8
136
137 * Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
138 - make kerberos support conditional at build-time
139
140 * Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
141 - integrate kerberos support into main tree
142
143 * Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
144 - build with gssapi auth (--with-gssapi, --with-encryption)
145 - apply patch to update libs to krb5 1.1.1
146
147 * Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
148 - fix the damn info pages too while we're at it.
149 - fix description
150 - man pages are compressed
151 - make sure %post and %preun work okay
152
153 * Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
154 - update to 1.10.7.
155
156 * Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
157 - add the patch to make 1.10.6 usable
158   (http://www.cyclic.com/cvs/dev-known.html).
159
160 * Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
161 - update to 1.10.6.
162
163 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
164 - auto rebuild in the new build environment (release 2)
165
166 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
167 - updated text in spec file.
168
169 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
170 - update to 1.10.5.
171
172 * Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
173 - update to 1.10.4.
174
175 * Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
176 - update to 1.10.3.
177
178 * Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
179 - update to 1.10.2.
180
181 * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
182 - remove trailing characters from rcs2log mktemp args
183
184 * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
185 - update to 1.10.1
186
187 * Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
188 - fix race conditions in cvsbug/rcs2log
189
190 * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
191 - update to 1.10.
192
193 * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
194 - update to 1.9.30.
195
196 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
197 - translations modified for de, fr
198
199 * Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
200 - build root
201 - update to 1.9.28
202
203 * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
204 - translations modified for de, fr, tr
205
206 * Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
207 - added install-info stuff
208 - added changelog section