44482f2115c61d489ef29785740421fd65f98f18
[nethome.git] / src / rpm / SPECS / cvs.spec
1 %define nokerberos 1
2 Summary: A version control system.
3 Name: cvs
4 Version: 1.11
5 Release: 3_nokerberos_static
6 Copyright: GPL
7 Group: Development/Tools
8 Source: ftp://ftp.cvshome.org/pub/cvs-%{version}/cvs-%{version}.tar.gz
9 URL: http://www.cvshome.org/
10 Patch0: cvs-1.10-tmprace.patch
11 Patch1: cvs-1.10.7-fixinfo.patch
12 Patch2: cvs-1.10.7-krb5-1.1.1.patch
13 Patch3: cvs-1.10.8-krb4.patch
14 Patch4: cvs-1.10.8-zlib.patch
15 Patch6: cvs-1.10.8-errno.patch
16 Patch7: cvs-1.11-security.patch
17 Patch8: cvs-1.11-existence.patch
18 Prereq: /sbin/install-info
19 Prefix: %{_prefix}
20 Buildroot: %{_tmppath}/%{name}-root
21 Requires: perl zlib
22 BuildPreReq: autoconf libtool zlib-devel
23 %{!?nokerberos:Requires: krb5-libs}
24 %{!?nokerberos:BuildPrereq: krb5-devel}
25
26 %description
27 CVS (Concurrent Version System) is a version control system which can
28 record the history of your files (usually, but not always, source
29 code). CVS only stores the differences between versions, instead of
30 every version of every file you've ever created. CVS also keeps a log
31 of who, when and why changes occurred.
32
33 CVS is very helpful for managing releases and controlling the
34 concurrent editing of source files among multiple authors. Instead of
35 providing version control for a collection of files in a single
36 directory, CVS provides version control for a hierarchical collection
37 of directories consisting of revision controlled files.  These
38 directories and files can then be combined together to form a software
39 release.
40
41 Install the cvs package if you need to use a version control system.
42
43 %prep
44 %setup -q
45 %patch0 -p1 -b .tmprace
46 %patch1 -p1 -b .fixinfo
47 %{!?nokerberos:%patch2 -p1 -b .krb5}
48 %{!?nokerberos:%patch3 -p1 -b .krb4}
49 %patch4 -p1 -b .zlib
50 %patch6 -p1 -b .errno
51 %patch7 -p1 -b .security
52 %patch8 -p1 -b .existence
53
54 %build
55 autoheader
56 autoconf
57 export LDFLAGS="-s -static"
58 %configure \
59 %{!?nokerberos: --with-gssapi=/usr/kerberos --with-krb4=/usr/kerberos --enable-encryption}
60
61 make
62 make -C doc info
63
64 %install
65 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
66
67 %{makeinstall} install-info
68 gzip $RPM_BUILD_ROOT/%{_infodir}/cvs* || true
69
70 %clean
71 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
72
73 %post
74 /sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
75 /sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir 
76
77 %preun
78 if [ $1 = 0 ]; then
79     /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
80     /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
81 fi
82
83 %files
84 %defattr(-,root,root)
85 %doc BUGS FAQ MINOR-BUGS NEWS PROJECTS TODO README
86 %doc doc/*.ps
87 /%{_bindir}/cvs
88 /%{_bindir}/cvsbug
89 /%{_bindir}/rcs2log
90 /%{_mandir}/man1/cvs.1*
91 /%{_mandir}/man5/cvs.5*
92 /%{_mandir}/man8/cvsbug.8*
93 /%{_infodir}/cvs*
94 /%{_libdir}/cvs
95
96 %changelog
97 * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
98 - fix cvs-1.11-security.patch, which had CR-LF line terminators (#25090)
99 - check for and ignore ENOENT errors when attempting to remove symlinks (#25173)
100
101 * Mon Jan 08 2001 Preston Brown <pbrown@redhat.com>
102 - patch from Olaf Kirch <okir@lst.de> to do tmp files safely.
103
104 * Tue Oct 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
105 - 1.11
106
107 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
108 - automatic rebuild
109
110 * Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
111 - always zero errno before calling readdir (#10374)
112
113 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
114 - rebuild in new build environment (release 6)
115
116 * Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
117 - rebuild in new build environment (release 5)
118 - FHS tweaks
119 - actually gzip the info pages
120
121 * Wed May 10 2000 Nalin Dahyabhai <nalin@redhat.com>
122 - reverse sense of conditional kerberos dependency
123 - add kerberos IV patch from Ken Raeburn
124 - switch to using the system's zlib instead of built-in
125 - default to unstripped binaries
126
127 * Tue Apr  4 2000 Bill Nottingham <notting@redhat.com>
128 - eliminate explicit krb5-configs dependency
129
130 * Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
131 - 1.10.8
132
133 * Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
134 - make kerberos support conditional at build-time
135
136 * Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
137 - integrate kerberos support into main tree
138
139 * Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
140 - build with gssapi auth (--with-gssapi, --with-encryption)
141 - apply patch to update libs to krb5 1.1.1
142
143 * Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
144 - fix the damn info pages too while we're at it.
145 - fix description
146 - man pages are compressed
147 - make sure %post and %preun work okay
148
149 * Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
150 - update to 1.10.7.
151
152 * Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
153 - add the patch to make 1.10.6 usable
154   (http://www.cyclic.com/cvs/dev-known.html).
155
156 * Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
157 - update to 1.10.6.
158
159 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
160 - auto rebuild in the new build environment (release 2)
161
162 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
163 - updated text in spec file.
164
165 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
166 - update to 1.10.5.
167
168 * Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
169 - update to 1.10.4.
170
171 * Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
172 - update to 1.10.3.
173
174 * Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
175 - update to 1.10.2.
176
177 * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
178 - remove trailing characters from rcs2log mktemp args
179
180 * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
181 - update to 1.10.1
182
183 * Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
184 - fix race conditions in cvsbug/rcs2log
185
186 * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
187 - update to 1.10.
188
189 * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
190 - update to 1.9.30.
191
192 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
193 - translations modified for de, fr
194
195 * Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
196 - build root
197 - update to 1.9.28
198
199 * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
200 - translations modified for de, fr, tr
201
202 * Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
203 - added install-info stuff
204 - added changelog section