cvs UMASK_DFLT is now 022 instead of 002
[nethome.git] / src / rpm / SPECS / cvs.spec
1 %define nokerberos 1
2 Summary: A version control system.
3 Name: cvs
4 Version: 1.11
5 Release: 3_nokerberos_static
6 Copyright: GPL
7 Group: Development/Tools
8 Source: ftp://ftp.cvshome.org/pub/cvs-%{version}/cvs-%{version}.tar.gz
9 URL: http://www.cvshome.org/
10 Patch0: cvs-1.10-tmprace.patch
11 Patch1: cvs-1.10.7-fixinfo.patch
12 Patch2: cvs-1.10.7-krb5-1.1.1.patch
13 Patch3: cvs-1.10.8-krb4.patch
14 Patch4: cvs-1.10.8-zlib.patch
15 Patch6: cvs-1.10.8-errno.patch
16 Patch7: cvs-1.11-security.patch
17 Patch8: cvs-1.11-existence.patch
18 Patch100: cvs-1.11-umask022.patch
19 Prereq: /sbin/install-info
20 Prefix: %{_prefix}
21 Buildroot: %{_tmppath}/%{name}-root
22 Requires: perl zlib
23 BuildPreReq: autoconf libtool zlib-devel
24 %{!?nokerberos:Requires: krb5-libs}
25 %{!?nokerberos:BuildPrereq: krb5-devel}
26
27 %description
28 CVS (Concurrent Version System) is a version control system which can
29 record the history of your files (usually, but not always, source
30 code). CVS only stores the differences between versions, instead of
31 every version of every file you've ever created. CVS also keeps a log
32 of who, when and why changes occurred.
33
34 CVS is very helpful for managing releases and controlling the
35 concurrent editing of source files among multiple authors. Instead of
36 providing version control for a collection of files in a single
37 directory, CVS provides version control for a hierarchical collection
38 of directories consisting of revision controlled files.  These
39 directories and files can then be combined together to form a software
40 release.
41
42 Install the cvs package if you need to use a version control system.
43
44 %prep
45 %setup -q
46 %patch0 -p1 -b .tmprace
47 %patch1 -p1 -b .fixinfo
48 %{!?nokerberos:%patch2 -p1 -b .krb5}
49 %{!?nokerberos:%patch3 -p1 -b .krb4}
50 %patch4 -p1 -b .zlib
51 %patch6 -p1 -b .errno
52 %patch7 -p1 -b .security
53 %patch8 -p1 -b .existence
54 %patch100 -p1 -b .umask022
55
56 %build
57 autoheader
58 autoconf
59 export LDFLAGS="-s -static -L$HOME/staticnss -lc -lnss_files -lnss_dns -lresolv"
60 %configure \
61 %{!?nokerberos: --with-gssapi=/usr/kerberos --with-krb4=/usr/kerberos --enable-encryption}
62
63 make
64 make -C doc info
65
66 %install
67 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
68
69 %{makeinstall} install-info
70 gzip $RPM_BUILD_ROOT/%{_infodir}/cvs* || true
71
72 %clean
73 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
74
75 %post
76 /sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
77 /sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir 
78
79 %preun
80 if [ $1 = 0 ]; then
81     /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
82     /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
83 fi
84
85 %files
86 %defattr(-,root,root)
87 %doc BUGS FAQ MINOR-BUGS NEWS PROJECTS TODO README
88 %doc doc/*.ps
89 /%{_bindir}/cvs
90 /%{_bindir}/cvsbug
91 /%{_bindir}/rcs2log
92 /%{_mandir}/man1/cvs.1*
93 /%{_mandir}/man5/cvs.5*
94 /%{_mandir}/man8/cvsbug.8*
95 /%{_infodir}/cvs*
96 /%{_libdir}/cvs
97
98 %changelog
99 * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
100 - fix cvs-1.11-security.patch, which had CR-LF line terminators (#25090)
101 - check for and ignore ENOENT errors when attempting to remove symlinks (#25173)
102
103 * Mon Jan 08 2001 Preston Brown <pbrown@redhat.com>
104 - patch from Olaf Kirch <okir@lst.de> to do tmp files safely.
105
106 * Tue Oct 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
107 - 1.11
108
109 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
110 - automatic rebuild
111
112 * Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
113 - always zero errno before calling readdir (#10374)
114
115 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
116 - rebuild in new build environment (release 6)
117
118 * Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
119 - rebuild in new build environment (release 5)
120 - FHS tweaks
121 - actually gzip the info pages
122
123 * Wed May 10 2000 Nalin Dahyabhai <nalin@redhat.com>
124 - reverse sense of conditional kerberos dependency
125 - add kerberos IV patch from Ken Raeburn
126 - switch to using the system's zlib instead of built-in
127 - default to unstripped binaries
128
129 * Tue Apr  4 2000 Bill Nottingham <notting@redhat.com>
130 - eliminate explicit krb5-configs dependency
131
132 * Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
133 - 1.10.8
134
135 * Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
136 - make kerberos support conditional at build-time
137
138 * Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
139 - integrate kerberos support into main tree
140
141 * Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
142 - build with gssapi auth (--with-gssapi, --with-encryption)
143 - apply patch to update libs to krb5 1.1.1
144
145 * Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
146 - fix the damn info pages too while we're at it.
147 - fix description
148 - man pages are compressed
149 - make sure %post and %preun work okay
150
151 * Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
152 - update to 1.10.7.
153
154 * Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
155 - add the patch to make 1.10.6 usable
156   (http://www.cyclic.com/cvs/dev-known.html).
157
158 * Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
159 - update to 1.10.6.
160
161 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
162 - auto rebuild in the new build environment (release 2)
163
164 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
165 - updated text in spec file.
166
167 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
168 - update to 1.10.5.
169
170 * Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
171 - update to 1.10.4.
172
173 * Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
174 - update to 1.10.3.
175
176 * Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
177 - update to 1.10.2.
178
179 * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
180 - remove trailing characters from rcs2log mktemp args
181
182 * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
183 - update to 1.10.1
184
185 * Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
186 - fix race conditions in cvsbug/rcs2log
187
188 * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
189 - update to 1.10.
190
191 * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
192 - update to 1.9.30.
193
194 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
195 - translations modified for de, fr
196
197 * Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
198 - build root
199 - update to 1.9.28
200
201 * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
202 - translations modified for de, fr, tr
203
204 * Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
205 - added install-info stuff
206 - added changelog section