orig rh71
[nethome.git] / src / rpm / SPECS / cvs.spec
1 Summary: A version control system.
2 Name: cvs
3 Version: 1.11
4 Release: 3
5 Copyright: GPL
6 Group: Development/Tools
7 Source: ftp://ftp.cvshome.org/pub/cvs-%{version}/cvs-%{version}.tar.gz
8 URL: http://www.cvshome.org/
9 Patch0: cvs-1.10-tmprace.patch
10 Patch1: cvs-1.10.7-fixinfo.patch
11 Patch2: cvs-1.10.7-krb5-1.1.1.patch
12 Patch3: cvs-1.10.8-krb4.patch
13 Patch4: cvs-1.10.8-zlib.patch
14 Patch6: cvs-1.10.8-errno.patch
15 Patch7: cvs-1.11-security.patch
16 Patch8: cvs-1.11-existence.patch
17 Prereq: /sbin/install-info
18 Prefix: %{_prefix}
19 Buildroot: %{_tmppath}/%{name}-root
20 Requires: perl zlib
21 BuildPreReq: autoconf libtool zlib-devel
22 %{!?nokerberos:Requires: krb5-libs}
23 %{!?nokerberos:BuildPrereq: krb5-devel}
24
25 %description
26 CVS (Concurrent Version System) is a version control system which can
27 record the history of your files (usually, but not always, source
28 code). CVS only stores the differences between versions, instead of
29 every version of every file you've ever created. CVS also keeps a log
30 of who, when and why changes occurred.
31
32 CVS is very helpful for managing releases and controlling the
33 concurrent editing of source files among multiple authors. Instead of
34 providing version control for a collection of files in a single
35 directory, CVS provides version control for a hierarchical collection
36 of directories consisting of revision controlled files.  These
37 directories and files can then be combined together to form a software
38 release.
39
40 Install the cvs package if you need to use a version control system.
41
42 %prep
43 %setup -q
44 %patch0 -p1 -b .tmprace
45 %patch1 -p1 -b .fixinfo
46 %{!?nokerberos:%patch2 -p1 -b .krb5}
47 %{!?nokerberos:%patch3 -p1 -b .krb4}
48 %patch4 -p1 -b .zlib
49 %patch6 -p1 -b .errno
50 %patch7 -p1 -b .security
51 %patch8 -p1 -b .existence
52
53 %build
54 autoheader
55 autoconf
56 %configure \
57 %{!?nokerberos: --with-gssapi=/usr/kerberos --with-krb4=/usr/kerberos --enable-encryption}
58
59 make
60 make -C doc info
61
62 %install
63 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
64
65 %{makeinstall} install-info
66 gzip $RPM_BUILD_ROOT/%{_infodir}/cvs* || true
67
68 %clean
69 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
70
71 %post
72 /sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
73 /sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir 
74
75 %preun
76 if [ $1 = 0 ]; then
77     /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
78     /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
79 fi
80
81 %files
82 %defattr(-,root,root)
83 %doc BUGS FAQ MINOR-BUGS NEWS PROJECTS TODO README
84 %doc doc/*.ps
85 /%{_bindir}/cvs
86 /%{_bindir}/cvsbug
87 /%{_bindir}/rcs2log
88 /%{_mandir}/man1/cvs.1*
89 /%{_mandir}/man5/cvs.5*
90 /%{_mandir}/man8/cvsbug.8*
91 /%{_infodir}/cvs*
92 /%{_libdir}/cvs
93
94 %changelog
95 * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
96 - fix cvs-1.11-security.patch, which had CR-LF line terminators (#25090)
97 - check for and ignore ENOENT errors when attempting to remove symlinks (#25173)
98
99 * Mon Jan 08 2001 Preston Brown <pbrown@redhat.com>
100 - patch from Olaf Kirch <okir@lst.de> to do tmp files safely.
101
102 * Tue Oct 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
103 - 1.11
104
105 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
106 - automatic rebuild
107
108 * Mon Jul 10 2000 Nalin Dahyabhai <nalin@redhat.com>
109 - always zero errno before calling readdir (#10374)
110
111 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
112 - rebuild in new build environment (release 6)
113
114 * Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
115 - rebuild in new build environment (release 5)
116 - FHS tweaks
117 - actually gzip the info pages
118
119 * Wed May 10 2000 Nalin Dahyabhai <nalin@redhat.com>
120 - reverse sense of conditional kerberos dependency
121 - add kerberos IV patch from Ken Raeburn
122 - switch to using the system's zlib instead of built-in
123 - default to unstripped binaries
124
125 * Tue Apr  4 2000 Bill Nottingham <notting@redhat.com>
126 - eliminate explicit krb5-configs dependency
127
128 * Mon Mar 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
129 - 1.10.8
130
131 * Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
132 - make kerberos support conditional at build-time
133
134 * Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
135 - integrate kerberos support into main tree
136
137 * Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
138 - build with gssapi auth (--with-gssapi, --with-encryption)
139 - apply patch to update libs to krb5 1.1.1
140
141 * Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
142 - fix the damn info pages too while we're at it.
143 - fix description
144 - man pages are compressed
145 - make sure %post and %preun work okay
146
147 * Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
148 - update to 1.10.7.
149
150 * Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
151 - add the patch to make 1.10.6 usable
152   (http://www.cyclic.com/cvs/dev-known.html).
153
154 * Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
155 - update to 1.10.6.
156
157 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
158 - auto rebuild in the new build environment (release 2)
159
160 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
161 - updated text in spec file.
162
163 * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
164 - update to 1.10.5.
165
166 * Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
167 - update to 1.10.4.
168
169 * Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
170 - update to 1.10.3.
171
172 * Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
173 - update to 1.10.2.
174
175 * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
176 - remove trailing characters from rcs2log mktemp args
177
178 * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
179 - update to 1.10.1
180
181 * Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
182 - fix race conditions in cvsbug/rcs2log
183
184 * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
185 - update to 1.10.
186
187 * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
188 - update to 1.9.30.
189
190 * Mon Jun 08 1998 Prospector System <bugs@redhat.com>
191 - translations modified for de, fr
192
193 * Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
194 - build root
195 - update to 1.9.28
196
197 * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
198 - translations modified for de, fr, tr
199
200 * Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
201 - added install-info stuff
202 - added changelog section